// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([^"=.]+?)""#).unwrap();
let string = "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" >
<img src=\"picture.png\" alt=\"Picture\" width=\"800\" height=\"20\"/>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}