#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "url\(("|\')((?!http://|https://).*?)(?:\1)\)"
Local $sString = "url("file.gif")" & @CRLF & _
"("http://google.com/image.png")" & @CRLF & _
"url('https://example.com/file.jpg')" & @CRLF & _
"url('dir/dir/image.tiff')" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")