$re = '~url\(("|\')((?!http://|https://).*?)(?:\1)\)~';
$str = 'url("file.gif")
("http://google.com/image.png")
url(\'https://example.com/file.jpg\')
url(\'dir/dir/image.tiff\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);