re = /url\(("|\')((?!http:\/\/|https:\/\/).*?)(?:\1)\)/
str = 'url("file.gif")
("http://google.com/image.png")
url(\'https://example.com/file.jpg\')
url(\'dir/dir/image.tiff\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end