const regex = new RegExp('url\\(("|\\\\')((?!http://|https://).*?)(?:\\1)\\)', 'g')
const str = `url("file.gif")
("http://google.com/image.png")
url('https://example.com/file.jpg')
url('dir/dir/image.tiff')
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}