using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\((""|\')((?!http://|https://).*?)(?:\1)\)";
string input = @"url(""file.gif"")
(""http://google.com/image.png"")
url('https://example.com/file.jpg')
url('dir/dir/image.tiff')
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}