import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\((\"|\\')((?!http://|https://).*?)(?:\\1)\\)";
final String string = "url(\"file.gif\")\n"
+ "(\"http://google.com/image.png\")\n"
+ "url('https://example.com/file.jpg')\n"
+ "url('dir/dir/image.tiff')\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}