#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]\d+|[2-9])$"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"45" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"0" & @CRLF & _
"11" & @CRLF & _
"111" & @CRLF & _
"19" & @CRLF & _
"999" & @CRLF & _
"9999" & @CRLF & _
"10000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")