const regex = /^(?:[1-9]\d+|[2-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-9]\\d+|[2-9])$', 'gm')
const str = `1
2
3
45
9
10
0
11
111
19
999
9999
10000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}