package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9]\d+|[2-9])$`)
var str = `1
2
3
45
9
10
0
11
111
19
999
9999
10000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}