import re
regex = re.compile(r"^(?:[1-9]\d+|[2-9])$", flags=re.MULTILINE)
test_str = ("1\n"
"2\n"
"3\n"
"45\n"
"9\n"
"10\n"
"0\n"
"11\n"
"111\n"
"19\n"
"999\n"
"9999\n"
"10000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")