$re = '/^(?:[1-9]\d+|[2-9])$/m';
$str = '1
2
3
45
9
10
0
11
111
19
999
9999
10000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);