import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-9]\\d+|[2-9])$";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "45\n"
+ "9\n"
+ "10\n"
+ "0\n"
+ "11\n"
+ "111\n"
+ "19\n"
+ "999\n"
+ "9999\n"
+ "10000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}