# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="yt">([\s\S]*?)<\/div>/$1/gm;t' <<< "<div class=\"yt\">
<iframe>....Video code....</iframe>
</div>"