using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""yt"">([\s\S]*?)</div>";
string substitution = @"$1";
string input = @"<div class=""yt"">
<iframe>....Video code....</iframe>
</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}