#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<div class="yt">([\s\S]*?)</div>"
Local $sString = "<div class="yt">" & @CRLF & _
" <iframe>....Video code....</iframe>" & @CRLF & _
"</div>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)