const regex = new RegExp('<div class="yt">([\\s\\S]*?)</div>', 'gm')
const str = `<div class="yt">
<iframe>....Video code....</iframe>
</div>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);