#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!.*(\d*x\d*|Episode dated)).*) \((\d*)\)$"
Local $sString = "Every Witch Way 3x19 New Witch Order (2015)" & @CRLF & _
"The Tonight Show Starring Jimmy Fallon Episode dated 22 January 2015 (2015)" & @CRLF & _
"October Gale (2014)" & @CRLF & _
"Kung Pow: Enter the Fist (2002)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")