use strict;
my $str = 'Every Witch Way 3x19 New Witch Order (2015)
The Tonight Show Starring Jimmy Fallon Episode dated 22 January 2015 (2015)
October Gale (2014)
Kung Pow: Enter the Fist (2002)';
my $regex = qr/^((?!.*(\d*x\d*|Episode dated)).*) \((\d*)\)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}