using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!.*(\d*x\d*|Episode dated)).*) \((\d*)\)$";
string input = @"Every Witch Way 3x19 New Witch Order (2015)
The Tonight Show Starring Jimmy Fallon Episode dated 22 January 2015 (2015)
October Gale (2014)
Kung Pow: Enter the Fist (2002)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}