$re = '/^((?!.*(\d*x\d*|Episode dated)).*) \((\d*)\)$/m';
$str = 'Every Witch Way 3x19 New Witch Order (2015)
The Tonight Show Starring Jimmy Fallon Episode dated 22 January 2015 (2015)
October Gale (2014)
Kung Pow: Enter the Fist (2002)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);