import Foundation
let pattern = #"^((?!.*(\d*x\d*|Episode dated)).*) \((\d*)\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Every Witch Way 3x19 New Witch Order (2015)
The Tonight Show Starring Jimmy Fallon Episode dated 22 January 2015 (2015)
October Gale (2014)
Kung Pow: Enter the Fist (2002)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)