const regex = /^((?!.*(\d*x\d*|Episode dated)).*) \((\d*)\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!.*(\\d*x\\d*|Episode dated)).*) \\((\\d*)\\)$', 'gm')
const str = `Every Witch Way 3x19 New Witch Order (2015)
The Tonight Show Starring Jimmy Fallon Episode dated 22 January 2015 (2015)
October Gale (2014)
Kung Pow: Enter the Fist (2002)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}