using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z])0+";
string substitution = @"\1";
string input = @"e004_n07";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}