const regex = new RegExp('([a-zA-Z])0+', 'g')
const str = `e004_n07`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);