$re = '/([a-zA-Z])0+/';
$str = 'e004_n07';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;