package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z])0+`)
var str = `e004_n07`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}