import Foundation
let pattern = #"([a-zA-Z])0+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"e004_n07"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)