use strict;
my $str = 'e004_n07';
my $regex = qr/([a-zA-Z])0+/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";