#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(password|pwd|pass) *= *+((?=".*")"[^&{][^\s]*"|(?='.*')'[^&{][^\s]*'|(?=[^"'{&].*)[^\s]*)$"
Local $sString = "password = "test123ABc#&$"" & @CRLF & _
"pwd=test123ABc#&$" & @CRLF & _
"pwd = 'test123ABc#&$'" & @CRLF & _
"pass = 'test123456&'" & @CRLF & _
"" & @CRLF & _
"password=&testpw" & @CRLF & _
"pwd = "{test123@#"" & @CRLF & _
"password = "&&test123"" & @CRLF & _
"pass={test123@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")