$re = '/(password|pwd|pass) *= *+((?=".*")"[^&{][^\s]*"|(?=\'.*\')\'[^&{][^\s]*\'|(?=[^"\'{&].*)[^\s]*)$/m';
$str = 'password = "test123ABc#&$"
pwd=test123ABc#&$
pwd = \'test123ABc#&$\'
pass = \'test123456&\'
password=&testpw
pwd = "{test123@#"
password = "&&test123"
pass={test123@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);