import re
regex = re.compile(r"(password|pwd|pass) *= *+((?=\".*\")\"[^&{][^\s]*\"|(?='.*')'[^&{][^\s]*'|(?=[^\"'{&].*)[^\s]*)$", flags=re.MULTILINE)
test_str = ("password = \"test123ABc#&$\"\n"
"pwd=test123ABc#&$\n"
"pwd = 'test123ABc#&$'\n"
"pass = 'test123456&'\n\n"
"password=&testpw\n"
"pwd = \"{test123@#\"\n"
"password = \"&&test123\"\n"
"pass={test123@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")