re = /(password|pwd|pass) *= *+((?=".*")"[^&{][^\s]*"|(?='.*')'[^&{][^\s]*'|(?=[^"'{&].*)[^\s]*)$/m
str = 'password = "test123ABc#&$"
pwd=test123ABc#&$
pwd = \'test123ABc#&$\'
pass = \'test123456&\'
password=&testpw
pwd = "{test123@#"
password = "&&test123"
pass={test123@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end