import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(password|pwd|pass) *= *+((?=\".*\")\"[^&\\{][^\\s]*\"|(?='.*')'[^&\\{][^\\s]*'|(?=[^\"'\\{&].*)[^\\s]*)$";
final String string = "password = \"test123ABc#&$\"\n"
+ "pwd=test123ABc#&$\n"
+ "pwd = 'test123ABc#&$'\n"
+ "pass = 'test123456&'\n\n"
+ "password=&testpw\n"
+ "pwd = \"{test123@#\"\n"
+ "password = \"&&test123\"\n"
+ "pass={test123@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}