package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[fF][eE]80:(?::[0-9a-fA-F]{1,4}){2,2}(?:%[0-9a-zA-Z]{1,})?`)
var str = `fe80::dead:beef%eth0
fe80::dead:beef:dead:beef%eth0
fe80:dead:beef:dead:beef:dead:beef:dead%eth0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}