import re
regex = re.compile(r"[fF][eE]80:(?::[0-9a-fA-F]{1,4}){2,2}(?:%[0-9a-zA-Z]{1,})?", flags=re.MULTILINE)
test_str = ("fe80::dead:beef%eth0\n"
"fe80::dead:beef:dead:beef%eth0\n"
"fe80:dead:beef:dead:beef:dead:beef:dead%eth0\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")