const regex = new RegExp('[fF][eE]80:(?::[0-9a-fA-F]{1,4}){2,2}(?:%[0-9a-zA-Z]{1,})?', 'gm')
const str = `fe80::dead:beef%eth0
fe80::dead:beef:dead:beef%eth0
fe80:dead:beef:dead:beef:dead:beef:dead%eth0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}