using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-z]{2}-[A-Z]{2}\b";
string input = @"https://www.xbox.com/en-US/xbox-one?xr=shellnav
https://www.xbox.com/xbox-one?xr=shellnav";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}