import re
regex = re.compile(r"\b[a-z]{2}-[A-Z]{2}\b", flags=re.MULTILINE)
test_str = ("https://www.xbox.com/en-US/xbox-one?xr=shellnav\n"
"https://www.xbox.com/xbox-one?xr=shellnav")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")