re = /\b[a-z]{2}-[A-Z]{2}\b/m
str = 'https://www.xbox.com/en-US/xbox-one?xr=shellnav
https://www.xbox.com/xbox-one?xr=shellnav'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end