$re = '/\b[a-z]{2}-[A-Z]{2}\b/m';
$str = 'https://www.xbox.com/en-US/xbox-one?xr=shellnav
https://www.xbox.com/xbox-one?xr=shellnav';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);