package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-z]{2}-[A-Z]{2}\b`)
var str = `https://www.xbox.com/en-US/xbox-one?xr=shellnav
https://www.xbox.com/xbox-one?xr=shellnav`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}