// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-z]{2}-[A-Z]{2}\b").unwrap();
let string = "https://www.xbox.com/en-US/xbox-one?xr=shellnav
https://www.xbox.com/xbox-one?xr=shellnav";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}