using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'id'02)_(?'code'\w{3})_(?'heatingvalue'H|L)_(?'type'SE)(?'offset'[1-9][0-9]?)_(?'derivative'PHY|FUT) (?'period'SWS-)(?'yearfull'\b20(?'yearabbr'1[4-9]|[2-9][0-9])\b)-\b(?'month'0[4]|1[0])\b$";
string input = @"02_NBP_H_SE1_PHY SWS-2014-10
02_NBP_H_SE1_PHY SWS-2014-04
02_NBP_H_SE1_PHY SWS-2014-03
02_NBP_H_SE1_PHY SWS-2014-4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}