use strict;
my $str = '02_NBP_H_SE1_PHY SWS-2014-10
02_NBP_H_SE1_PHY SWS-2014-04
02_NBP_H_SE1_PHY SWS-2014-03
02_NBP_H_SE1_PHY SWS-2014-4
';
my $regex = qr/^(?'id'02)_(?'code'\w{3})_(?'heatingvalue'H|L)_(?'type'SE)(?'offset'[1-9][0-9]?)_(?'derivative'PHY|FUT) (?'period'SWS-)(?'yearfull'\b20(?'yearabbr'1[4-9]|[2-9][0-9])\b)-\b(?'month'0[4]|1[0])\b$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}