package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?'id'02)_(?'code'\w{3})_(?'heatingvalue'H|L)_(?'type'SE)(?'offset'[1-9][0-9]?)_(?'derivative'PHY|FUT) (?'period'SWS-)(?'yearfull'\b20(?'yearabbr'1[4-9]|[2-9][0-9])\b)-\b(?'month'0[4]|1[0])\b$`)
var str = `02_NBP_H_SE1_PHY SWS-2014-10
02_NBP_H_SE1_PHY SWS-2014-04
02_NBP_H_SE1_PHY SWS-2014-03
02_NBP_H_SE1_PHY SWS-2014-4
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}