const regex = /^(?'id'02)_(?'code'\w{3})_(?'heatingvalue'H|L)_(?'type'SE)(?'offset'[1-9][0-9]?)_(?'derivative'PHY|FUT) (?'period'SWS-)(?'yearfull'\b20(?'yearabbr'1[4-9]|[2-9][0-9])\b)-\b(?'month'0[4]|1[0])\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'id\'02)_(?\'code\'\\w{3})_(?\'heatingvalue\'H|L)_(?\'type\'SE)(?\'offset\'[1-9][0-9]?)_(?\'derivative\'PHY|FUT) (?\'period\'SWS-)(?\'yearfull\'\\b20(?\'yearabbr\'1[4-9]|[2-9][0-9])\\b)-\\b(?\'month\'0[4]|1[0])\\b$', 'gm')
const str = `02_NBP_H_SE1_PHY SWS-2014-10
02_NBP_H_SE1_PHY SWS-2014-04
02_NBP_H_SE1_PHY SWS-2014-03
02_NBP_H_SE1_PHY SWS-2014-4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}