re = /^(?'id'02)_(?'code'\w{3})_(?'heatingvalue'H|L)_(?'type'SE)(?'offset'[1-9][0-9]?)_(?'derivative'PHY|FUT) (?'period'SWS-)(?'yearfull'\b20(?'yearabbr'1[4-9]|[2-9][0-9])\b)-\b(?'month'0[4]|1[0])\b$/m
str = '02_NBP_H_SE1_PHY SWS-2014-10
02_NBP_H_SE1_PHY SWS-2014-04
02_NBP_H_SE1_PHY SWS-2014-03
02_NBP_H_SE1_PHY SWS-2014-4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end