import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'id'02)_(?'code'\\w{3})_(?'heatingvalue'H|L)_(?'type'SE)(?'offset'[1-9][0-9]?)_(?'derivative'PHY|FUT) (?'period'SWS-)(?'yearfull'\\b20(?'yearabbr'1[4-9]|[2-9][0-9])\\b)-\\b(?'month'0[4]|1[0])\\b$";
final String string = "02_NBP_H_SE1_PHY SWS-2014-10\n"
+ "02_NBP_H_SE1_PHY SWS-2014-04\n"
+ "02_NBP_H_SE1_PHY SWS-2014-03\n"
+ "02_NBP_H_SE1_PHY SWS-2014-4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}