const regex = /(?:(?:###)?([^# \n]+))(?=$|(?:###[^# ]+)*[^\n]*?(http:\/\/[^\n]+))(?: http:\/\/[^\n]+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:###)?([^# \\n]+))(?=$|(?:###[^# ]+)*[^\\n]*?(http:\\\/\\\/[^\\n]+))(?: http:\\\/\\\/[^\\n]+)?', 'g')
const str = `a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn http://www.zjmainstay.cn/my-regexp
a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn###a4@zjmainstay.cn###a5@zjmainstay.cn http://www.zjmainstay.cn/deep-regexp`;
const subst = `$1 $2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);